关于Tensorflow安装的版本问题

博主这里想要强调一点,如果大家在运行python时输入import tensorflow as tf出现了importError: libcudnn.so.6: cannot open shared object file: No such file or directory这个错误,很有可能是cudnn版本的问题,这里的so.6指的是版本6。

例如,CUDA8.0+cudnnv7.1+tensorflow-gpu==1.4一定会报错,因为cudnn7.1太高了,是版本7,CUDA8.0最高cudnnv6版本,因此需要重新下载cudnn,Tensorflow装了就可以不卸载了~

还有一个问题,就是电脑显卡不好的,CUDA9.0基本上可以放弃了,CUDA8.0是合适的,否则在安装完CUDA进行sample测试时,result失败,极有可能显示驱动程序不满足CUDA的配置!!!1点多GB的流量白瞎了!!

这里可以告诉大家,GTX 880M安装CUDA9.1就会出现不满足的情况,所以可以安装低版本的CUDA8.0进行测试~

总之,就是版本一定不要都装最新的,而是看匹配,这才是最重要的!

悲恋花丶无心之人 CSDN认证博客专家 深度学习 神经网络 Pytorch
计算机视觉在读研究生,熟悉Pytorch,MXNet,TensorFlow,Keras等深度学习框架,主要涉及的领域有目标检测,语义分割,超分辨率重建,行人重识别等。
个人GitHub网址为:https://github.com/nickhuang1996
相关推荐
©️2020 CSDN 皮肤主题: 博客之星2020 设计师:CY__ 返回首页
实付 29.90元
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值